Home page logo
/

nmap-dev logo Nmap Development mailing list archives

Re: nmap 6.0/Zenmap hang on OS X 10.7.4
From: David Fifield <david () bamsoftware com>
Date: Tue, 29 May 2012 15:35:04 -0700

On Wed, May 23, 2012 at 12:11:57PM -0700, David Newman wrote:
On 5/21/12 2:16 PM, David Fifield wrote:
On Mon, May 21, 2012 at 02:11:26PM -0700, David Newman wrote:
nmap/Zenmap 6.00
OS X 10.7.4
XQuartz 2.6.4 (xorg-server 1.10.6)

Zenmap usually (but not always) hangs after nmap completes a scan using
default -T4 -A -v flags.

The behavior that precedes the hang is (1) moving the scrollbar in
Zenmap's Nmap Output tab and (2) attempting to click on the Topology tab.

After the hang there's always this error in the OS X Console:

5/21/12 1:17:55.356 PM [0x0-0x56056].org.insecure.Zenmap: GError:
Couldn't recognize the image file format for file
'/Applications/Zenmap.app/Contents/MacOS/../Resources/share/zenmap/pixmaps/radialnet/padlock.png'

There's a similar entry in changelog 28642 for a previous tweak for this
issue.

Thanks for this report. Is your XQuartz server the default X11 server
that Apple provides, or one you installed separately?

FYI the previous hangs were when scanning subnets, not individual hosts.
Today I was able to reproduce the hang after a scan of one host. Again,
the hang occurred on step 2 above, when clicking on the Topology tab.
The OS X Console app had the same file-format error message.

Did you upgrade from a previous version of Zenmap? Does the problem
persist if you delete the /Applications/Zenmap.app directory and
reinstall?

David Fifield
_______________________________________________
Sent through the nmap-dev mailing list
http://cgi.insecure.org/mailman/listinfo/nmap-dev
Archived at http://seclists.org/nmap-dev/


  By Date           By Thread  

Current thread:
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]