Home page logo
/

nmap-dev logo Nmap Development mailing list archives

Re: nmap v6.00 - problems if a wlan interface is installed/activated
From: Djalal Harouni <tixxdz () opendz org>
Date: Thu, 28 Jun 2012 01:42:41 +0100

Hi Tom,

On Sun, Jun 03, 2012 at 06:26:39PM +0200, Tom Eichstaedt wrote:
[...]
**************************ROUTES**************************
DST/MASK         DEV    GATEWAY
xxx.xxx.xxx.xxx/32 ppp0
10.100.0.0/24    lan-1
10.100.1.0/24    wlan-1
192.168.2.0/24   wan-1
0.0.0.0/0        ppp0   217.0.118.108
=======================================================================

As you can see nmap 5.51 finds the routes on the same box but patched 
nmap v6.00 still does not.

I don't know if this is really important. I just want to let you know 
about this issue. If you need further information, please let me know.
I think that we have a workaround for Linux, however currently the
provided solution is still under discussion [1]

Testing the patch will at least confirm to us if the 'find ppp routes'
logic is still working. So could you please try the following:
http://seclists.org/nmap-dev/2012/q2/att-920/nmap_routes_rework.patch

This should apply to Nmap-6.01, use 'patch -p1'.

Thanks

[1]  http://seclists.org/nmap-dev/2012/q2/920

-- 
tixxdz
http://opendz.org
_______________________________________________
Sent through the nmap-dev mailing list
http://cgi.insecure.org/mailman/listinfo/nmap-dev
Archived at http://seclists.org/nmap-dev/


  By Date           By Thread  

Current thread:
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]