Home page logo
/

nmap-dev logo Nmap Development mailing list archives

RE: Nmap 5.50 script engine error
From: Rob Nicholls <robert () robnicholls co uk>
Date: Tue, 23 Jul 2013 09:57:32 +0100

On 22.07.2013 20:05, Bellingar, Richard J. (RET-DAY) wrote:
I'm working on the upgrade (corporate red tape) but if anyone has
ideas on how to make 5.5 work, I'd appreciate hearing them.

Error messages like those are frequently seen when you try to run a newer script with an older version of Nmap. Occasionally there are fundamental changes to scripts, their libraries and/or nse_main.lua that will prevent new scripts from working with old versions of Nmap.

You could try editing ip-forwarding.nse to replace SCRIPT_NAME with a string (i.e. "ip-forwarding"). I think all the other libraries (e.g. dns, packet, string, ipOps) exist in your version, but you may run into further problems at which point you might be out of luck.

Rob

_______________________________________________
Sent through the dev mailing list
http://nmap.org/mailman/listinfo/dev
Archived at http://seclists.org/nmap-dev/


  By Date           By Thread  

Current thread:
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]