Home page logo
/

nmap-dev logo Nmap Development mailing list archives

Re: Zenmap 6.40 crashes immediately when launched in Mac OS X 10.5 (Intel), command line nmap works
From: David Fifield <david () bamsoftware com>
Date: Thu, 8 Aug 2013 21:58:27 -0700

On Mon, Jul 29, 2013 at 03:55:02PM +0300, Lubo Diakov wrote:
Starting Nmap 6.40 ( http://nmap.org ) at 2013-07-29 15:47 EEST
Nmap scan report for 192.168.63.1
Host is up (0.015s latency).
Not shown: 999 closed ports
PORT   STATE SERVICE
80/tcp open  http
MAC Address: 00:14:BF:09:0C:7A (Cisco-Linksys)

Nmap done: 1 IP address (1 host up) scanned in 3.15 seconds

Please advise me of possible workarounds (I do not have Xcode installed
sadly). Maybe installing Xquartz as it is a slightly newer (and hopefully
less buggy) X11 than Apple's? Though I should add that Wireshark works
fine, so it is not entirely Apple's fault.

Crash report from Console.app
-----
Process:         X11.bin [15527]
Path:            /Applications/Utilities/X11.app/Contents/MacOS/X11.bin
Identifier:      org.x.X11
Version:         2.1.6 (2.1.6)
Build Info:      X11server-480700~8
Code Type:       X86 (Native)
Parent Process:  X [15526]

Interval Since Last Report:          5384 sec
Crashes Since Last Report:           1
Per-App Interval Since Last Report:  310 sec
Per-App Crashes Since Last Report:   1

Date/Time:       2013-07-29 15:40:30.782 +0300
OS Version:      Mac OS X 10.5.8 (9L31a)
Report Version:  6
Anonymous UUID:  18FC0C2E-1557-425E-811C-6D40744D2216

Exception Type:  EXC_BAD_ACCESS (SIGBUS)
Exception Codes: KERN_PROTECTION_FAILURE at 0x0000000000000000
Crashed Thread:  2

Thanks for this report. Here are some relevant links I found by
searching for "X11server-480700", all having to do with X11 crashes on
10.5.

"Wireshark crashes on OSX 10.5 on startup, from macports"
http://ask.wireshark.org/questions/6388/wireshark-crashes-on-osx-105-on-startup-from-macports
"Trying to open inkscape version 0.48.2 it crash the x11 on my Mac OS X ver. 10.5.8 . "
https://bugs.launchpad.net/inkscape/+bug/878368
"Gramps crashes X11.app in RootlessGlyphs on 10.5"
https://trac.macports.org/ticket/29642

The links suggest that using a newer X11 server or Xquartz may help,
because it is a bug in the X11 server that comes with 10.5.
Unfortunately, I don't think it's likely the bug will ever be fixed,
because 10.5 is no longer supported by Apple.

David Fifield
_______________________________________________
Sent through the dev mailing list
http://nmap.org/mailman/listinfo/dev
Archived at http://seclists.org/nmap-dev/


  By Date           By Thread  

Current thread:
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]
AlienVault