Home page logo
/

nmap-dev logo Nmap Development mailing list archives

Re: Call for test: WinPcap 4.1.4 (NPcap 1.0.0)
From: "veotax" <hsluoyz () qq com>
Date: Fri, 9 Aug 2013 22:42:48 +0800

Hi Jacek,


Perhaps I need to reproduce the error with your environment to see what's going on with NPcap.
I know you are running a x64 system. So what is the detailed version of your system? (Win7, Server 2008 R2, Win8, 
Server2012). and what is the edition? (basic, professional, enterprise, ultimate and so on). Are there anti-virus or 
firewall softwares installed? And any other information that may concern with it. I will set up an environment that is 
nearly the same as yours and test the driver installation. Thanks for your reply.




Yours,
Yang Luo




------------------ Original ------------------
From:  "Jacek Wielemborek"<wielemborekj1 () gmail com>;
Date:  Fri, Aug 9, 2013 10:12 PM
To:  "veotax"<hsluoyz () qq com>; 
Cc:  "dev"<dev () nmap org>; 
Subject:  Re: Call for test: WinPcap 4.1.4 (NPcap 1.0.0)



2013/8/9 veotax <hsluoyz () qq com>:
Hi, Jacek,

Thanks for your reply. It seems that you are running a Win7(8) x64 system,
right? This problem can be possibly caused by that you didn't enter the
"disable driver signature enforcement" mode. Because our NPcap driver is
still unsigned, x64 Windows above Win7 will deny any unsigned driver
installation without running under that mode. Here're some links that may be
helpful for you to enter that mode:

If you are running a Win7 x64 system:

http://sabrent.com/support/knowledgebase.php?article=14

If you are running a Win8 x64 system:

http://sixcolumns.com/t/how-to-disable-and-bypass-driver-signature-enforcement-in-windows-8/151

We have placed the order for a driver license and in a week or two, you can
test the signed version driver. At that time, no need to enter the mode any
more:)


Yours,
Yang Luo

------------------ Original ------------------
From:  "Jacek Wielemborek"<wielemborekj1 () gmail com>;
Date:  Fri, Aug 9, 2013 08:20 PM
To:  "veotax"<hsluoyz () qq com>;
Cc:  "dev"<dev () nmap org>;
Subject:  Re: Call for test: WinPcap 4.1.4 (NPcap 1.0.0)

Hi Yang,

I tried out your Npcap and I have no good news - it failed to work for
me. I'm no Windows expert, so I'll just copy over the installation log
and the error message Nmap gave me when I tried to run it after
testing:

Output folder: C:\Windows\system32
Extract: pthreadVC.dll
Extract: wpcap.dll
Windows CurrentVersion: 6.1
Extract: Packet.dll
Output folder: C:\Program Files\WinPcap
Extract: rpcapd.exe
Extract: LICENSE
Extract: NPF6xInstall.exe
Extract: npf6x.sys
Extract: npf6x.inf
Created uninstaller: C:\Program Files\WinPcap\uninstall.exe
Installing NDIS6.x x64 driver for Win7 and Win8
Output folder: C:\Windows\system32\drivers
Output folder: C:\Windows\system32
Extract: wpcap.dll
Extract: Packet.dll
Execute: "C:\Program Files\WinPcap\NPF6xInstall.exe" -i
Failed to create the npf service for Win7 and Win8
Completed

And the Nmap error:

dnet: Failed to open device eth0
QUITTING!

Restoring WinPcap fixed the problem. Let me know how can I help you
track down the issue.

Yours,
Jacek Wielemborek
_______________________________________________
Sent through the dev mailing list
http://nmap.org/mailman/listinfo/dev
Archived at http://seclists.org/nmap-dev/
.

Hi Yang,

Unfortunately, following your advice didn't change anything.

Yours,
Jacek Wielemborek
_______________________________________________
Sent through the dev mailing list
http://nmap.org/mailman/listinfo/dev
Archived at http://seclists.org/nmap-dev/
.
_______________________________________________
Sent through the dev mailing list
http://nmap.org/mailman/listinfo/dev
Archived at http://seclists.org/nmap-dev/


  By Date           By Thread  

Current thread:
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]
AlienVault