Home page logo
/

nmap-dev logo Nmap Development mailing list archives

Re: Call for test: WinPcap 4.1.3 for Nmap (NPcap 1.0)
From: "veotax" <hsluoyz () qq com>
Date: Tue, 27 Aug 2013 00:19:29 +0800

Hi Jacek,


I can't explain why you still encountered that message box after wpcap.dll is deleted. If you take a look at the Line 
223 at WinPcap 4.1.3 for Nmap installer NSIS script 
(https://svn.nmap.org/nmap-exp/yang/NPcap-LWF/installer/NPcap-for-nmap.nsi), you will see that if the wpcap.dll file 
does not exist, the installer won't do the version checking, nor the message box will show up. Maybe you can help me 
take a look at that part of the script? Thanks.




Cheers,
Yang






------------------ Original ------------------
From:  "Jacek Wielemborek"<wielemborekj1 () gmail com>;
Date:  Mon, Aug 26, 2013 09:43 PM
To:  "veotax"<hsluoyz () qq com>; 
Cc:  "dev"<dev () nmap org>; 
Subject:  Re: Call for test: WinPcap 4.1.3 for Nmap (NPcap 1.0)



2013/8/18 veotax <hsluoyz () qq com>:
Thanks for your reply. If you received the "Skipping WinPcap installation
since version 4.1.0.3001 already exists on this system.  Uninstall that
version first if you wish to force install." message, You could just delete
the wpcap.dll in your system32 dir to avoid the message and reinstall it
again. Sometimes the installer reports "Failed to create the npf service for
Win7 and Win8", but it is maybe already successfully installed. So even the
installer fails, you can have a try for Nmap or Wireshark to see the actual
effect. The method above is some kind of bypass way, and I will figure on
how to fix it.

Cheers,
Yang


------------------ Original ------------------
From:  "Jacek Wielemborek"<wielemborekj1 () gmail com>;
Date:  Sun, Aug 18, 2013 01:54 AM
To:  "veotax"<hsluoyz () qq com>;
Cc:  "dev"<dev () nmap org>;
Subject:  Re: Call for test: WinPcap 4.1.3 for Nmap (NPcap 1.0)

2013/8/17 veotax <hsluoyz () qq com>:
Hi, everyone. I got the code signing license just now and had WinPcap
4.1.3 for Nmap signed. Now you guys can test NPcap installer without
entering the boring test mode!
The wpcap.dll version bug was repaired according to the feedback. And I
have tested it under Windows 7 x64 and Windows 8 x64.
revision:31892
The installer
only:https://svn.nmap.org/nmap-exp/yang/NPcap-LWF/installer/winpcap-nmap-4.1.3-NDIS6-1.0.exe
The entire code base:https://svn.nmap.org/nmap-exp/yang/NPcap-LWF
Notice: Save your data in case your system suddenly crashes for BSoD.
Cheers,Yang
_______________________________________________
Sent through the dev mailing list
http://nmap.org/mailman/listinfo/dev
Archived at http://seclists.org/nmap-dev/

Hi,

I'm still getting the error message:

---------------------------
WinPcap 4.1.3 for Nmap (NPcap) Setup
---------------------------
Failed to create the npf service for Win7 and Win8. Please try
installing WinPcap again, or use the official WinPcap installer from
www.winpcap.org
---------------------------
OK
---------------------------

What I did was uninstalling the original WinPcap and then trying to
install your version. I forgot to reboot though, so that might be the
cause. When after rebooting I tried to run your installer again,
here's what I got:

---------------------------
WinPcap 4.1.3 for Nmap (NPcap) Setup
---------------------------
Skipping WinPcap installation since version 4.1.0.3001 already exists
on this system.  Uninstall that version first if you wish to force
install.
---------------------------
OK
---------------------------

I couldn't find your WinPcap in the add/remove menu.

Yours,
Jacek Wielemborek
_______________________________________________
Sent through the dev mailing list
http://nmap.org/mailman/listinfo/dev
Archived at http://seclists.org/nmap-dev/
.

Hi again,

I removed the wpcap.dll, tried to uninstall WinPcap and the message
box appears again:

---------------------------
WinPcap 4.1.3 for Nmap (NPcap) Setup
---------------------------
Skipping WinPcap installation since version 4.1.0.3001 already exists
on this system.  Uninstall that version first if you wish to force
install.
---------------------------
OK
---------------------------

I tried uninstalling Nmap as well, nothing helped.

Jacek Wielemborek
_______________________________________________
Sent through the dev mailing list
http://nmap.org/mailman/listinfo/dev
Archived at http://seclists.org/nmap-dev/
.
_______________________________________________
Sent through the dev mailing list
http://nmap.org/mailman/listinfo/dev
Archived at http://seclists.org/nmap-dev/


  By Date           By Thread  

Current thread:
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]
AlienVault