Home page logo
/

nmap-dev logo Nmap Development mailing list archives

Re: [NSE] Created NSE script to detect version of SPIP install
From: Paul AMAR <aos.paul () gmail com>
Date: Tue, 11 Feb 2014 20:07:01 +0100

Hi George,

First of all, thanks for the feedback.
Here is a patch for the SPIP installs then.

Good evening,
Paul


2014-02-10 23:08 GMT+01:00 George Chatzisofroniou <sophron () latthi com>:

Hi Paul,

On Mon, Feb 10, 2014 at 10:38:25PM +0100, Paul AMAR wrote:
I developed a NSE script that detects the version of a SPIP install.
At the moment, the script is looking for the version in the HTTP Header
(Composed-by) which is the most common technique.

I'll also (if it failed) add another technique to look in the HTML body
instead,  in few days/weeks.

There is http-devframework for detecting the underlying tool of a website
so I
think you should add this as an entry in data/http-tools-fingerprints.lua.

--
George Chatzisofroniou

Attachment: spip.patch
Description:

_______________________________________________
Sent through the dev mailing list
http://nmap.org/mailman/listinfo/dev
Archived at http://seclists.org/nmap-dev/

  By Date           By Thread  

Current thread:
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]