Home page logo
/

oss-sec logo oss-sec mailing list archives

CVE Request -- WeeChat (prior to 0.3.9.1): Heap-based buffer overflow when decoding IRC colors in strings
From: Jan Lieskovsky <jlieskov () redhat com>
Date: Sat, 10 Nov 2012 07:29:07 -0500 (EST)

Hello Kurt, Steve, vendors,

  WeeChat upstream has released 0.3.9.1 version, correcting
one (heap-based) buffer overflow flaw.

References:
[1] http://weechat.org/
[2] http://weechat.org/security/
[3] https://savannah.nongnu.org/bugs/?37704
[4] https://bugzilla.redhat.com/show_bug.cgi?id=875181

Relevant upstream patch:
[5] http://git.savannah.gnu.org/gitweb/?p=weechat.git;a=commitdiff;h=9453e81baa7935db82a0b765a47cba772aba730d

Could you allocate a CVE id for this?

Thank you && Regards, Jan.
--
Jan iankko Lieskovsky / Red Hat Security Response Team


  By Date           By Thread  

Current thread:
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]