Home page logo
/

oss-sec logo oss-sec mailing list archives

CVE-2013-0288 nss-pam-ldapd: FD_SET array index error, leading to stack-based buffer overflow
From: Jan Lieskovsky <jlieskov () redhat com>
Date: Mon, 18 Feb 2013 12:29:14 -0500 (EST)

Hello Steve, vendors,

  an array index error, leading to stack-based buffer overflow
flaw was found in the way nss-pam-ldapd, a PAM and nsswitch module
which uses directory servers, performed management of file descriptors
when performing file descriptors activity wait. An attacker could use
this flaw to cause processes with a large number of opened file
descriptors, that performed name lookups to crash or, potentially,
execute arbitrary code with the privileges of the user running the process.

Upstream advisory (with patches and further details)
[1] http://arthurdejong.org/nss-pam-ldapd/CVE-2013-0288

References:
[2] https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2013-0288

Credit: This issue was found by Garth Mollett.

Red Hat would like to thank Garth Mollett for reporting this
issue, and Arthur de Jong of nss-pam-ldapd upstream for help
with coordination of this advisory.

Thank you && Regards, Jan.
--
Jan iankko Lieskovsky / Red Hat Security Response Team


  By Date           By Thread  

Current thread:
  • CVE-2013-0288 nss-pam-ldapd: FD_SET array index error, leading to stack-based buffer overflow Jan Lieskovsky (Feb 18)
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]