Home page logo
/

oss-sec logo oss-sec mailing list archives

CVE request: XSS flaw in Ganglia web interface
From: Murray McAllister <mmcallis () redhat com>
Date: Tue, 26 Nov 2013 14:54:01 +1100

Hello,

A cross-site scripting (XSS) flaw was discovered in the Ganglia web interface:

https://github.com/ganglia/ganglia-web/issues/218
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=730507

Quoting from the original report:

""
Temporary Workaround and Fix
============================
Apply the following patch to properly encode the variable:

--- header.php.old      2013-09-30 21:07:26.272287657 +0200
+++ header.php  2013-09-30 21:09:42.226281990 +0200
@@ -491,7 +491,7 @@ $data->assign("custom_time", $custom_tim
 /////////////////////////////////////////////////////////////////////////
 if ( $context == "cluster" ) {
   if ( isset($user['host_regex']) && $user['host_regex'] != "" )
-    $set_host_regex_value="value='" . $user['host_regex'] . "'";
+ $set_host_regex_value="value='" . htmlentities($user['host_regex'], ENT_QUOTES) . "'";
   else
     $set_host_regex_value="";
""

The fix does not apply to the older versions in EPEL (3.0.7 and 3.1.7), but I did not test to see if they were affected.

Can a CVE please be assigned if one has not been already?

Thanks,

--
Murray McAllister / Red Hat Security Response Team


  By Date           By Thread  

Current thread:
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]