Home page logo
/

snort logo Snort mailing list archives

Re: Snort 2.8->2.9 upgrade, DAQ and libpcap
From: Joel Esler <jesler () sourcefire com>
Date: Fri, 18 May 2012 09:19:33 -0400

As noted in the blog post you reference below:

PCAP ≥ 1.0.0. PCAP 1.1.1 is available at the time of this writing and is recommended.

So..  Yes.  You'll need to download, compile, and install libpcap 1.0.0 or higher.

Joel

On May 18, 2012, at 1:46 AM, Maurizio Molina wrote:

Hi,
I'm trying to upgrade from 2.8 to 2.9.2.3, and I'm getting this error

checking for dlsym in -ldl... yes
./configure: line 15188: daq-modules-config: command not found
checking for daq_load_modules in -ldaq_static... no

   ERROR! daq_static library not found, go get it from
   http://www.snort.org/.
make: *** [snort_configure] Error 1

and from what I read here:
http://vrt-blog.snort.org/2010/08/snort-29-essentials-daq.html
pcap > 1.0.0 is required. I am still running pcap 0.9.8

Can somebody confirm that I can't continue working with the old pcap 
version?

Thanks,
Maurizio Molina


------------------------------------------------------------------------------
Live Security Virtual Conference
Exclusive live event will cover all the ways today's security and 
threat landscape has changed and how IT managers can respond. Discussions 
will include endpoint security, mobile security and the latest in malware 
threats. http://www.accelacomm.com/jaw/sfrnl04242012/114/50122263/
_______________________________________________
Snort-users mailing list
Snort-users () lists sourceforge net
Go to this URL to change user options or unsubscribe:
https://lists.sourceforge.net/lists/listinfo/snort-users
Snort-users list archive:
http://www.geocrawler.com/redir-sf.php3?list=snort-users

Please visit http://blog.snort.org to stay current on all the latest Snort news!

  By Date           By Thread  

Current thread:
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]