Home page logo
/

wireshark logo Wireshark mailing list archives

Re: make distcheck does not work if configured for GTK2
From: Guy Harris <guy () alum mit edu>
Date: Wed, 21 Aug 2013 11:43:18 -0700


On Aug 21, 2013, at 11:16 AM, Guy Harris <guy () alum mit edu> wrote:

so we probably should have the configure-script code that chooses which GUI toolkits to use (if any) set 
AM_DISTCHECK_CONFIGURE_FLAGS.  I'll look at doing that.

Done.

This also means that if --with-qt was specified, "make distcheck" will use it - and, if it was used with --with-gtk2 or 
--with-gtk3, "make distcheck" will use both.

*If* it's possible to do so, should we, if no --with-{gtk2,gtk3,qt} option was specified, default to building with the 
latest version of GTK+ that we have (GTK+ 3 if we have it, GTK+ 2 if we don't), and fail if neither is present (if 
neither is present, you'd have to use --disable-wireshark, just as you do now)?

___________________________________________________________________________
Sent via:    Wireshark-dev mailing list <wireshark-dev () wireshark org>
Archives:    http://www.wireshark.org/lists/wireshark-dev
Unsubscribe: https://wireshark.org/mailman/options/wireshark-dev
             mailto:wireshark-dev-request () wireshark org?subject=unsubscribe


  By Date           By Thread  

Current thread:
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]