Home page logo
/

wireshark logo Wireshark mailing list archives

Re: Build instability
From: Kaul <mykaul () gmail com>
Date: Mon, 9 Dec 2013 14:49:07 +0200

Opened https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=9529 on the
issue.


On Sun, Dec 8, 2013 at 9:52 PM, Jakub Zawadzki <darkjames-ws () darkjames pl>wrote:

On Sun, Dec 08, 2013 at 09:23:23PM +0200, Kaul wrote:
Thanks for the automated build links - I guess I'll watch them more
closely
and only sync when my platform passes.

Interesting - I'm pulling from trunk and still fail on that. Perhaps it
wasn't fixed entirely, or I have to do some cleanup?

I agree, it isn't fixed, from_hex() is defined inside:
  #if defined(HAVE_LIBGNUTLS) && defined(HAVE_LIBGCRYPT)

but it's used outside this #ifdef.


Kuba.



On Sun, Dec 8, 2013 at 6:51 PM, Hauke Mehrtens <hauke () hauke-m de> wrote:

On 12/08/2013 04:30 PM, Kaul wrote:
Hi all,

I've been trying to enhance a specific dissector for two weeks now.
Since I'm afraid of diverging the code (although I'm working on a
specific dissector), I update my code base often (~ once a day).
Regretfully, 5 times (in 2 weeks!) this has resulted in compilation
failure.
I'm pretty sure (subjectively) this hasn't happened in the past. Any
measures we can put (continuous build system?) in place to prevent
this?

Today's failure (2nd failure only today btw):
make[5]: Entering directory `/home/yanivk/wireshark/epan/dissectors'
  CC       libdissectors_la-packet-ssl-utils.lo
packet-ssl-utils.c: In function 'ssl_keylog_parse_session_id':
packet-ssl-utils.c:4201:9: error: implicit declaration of function
'from_hex_char' [-Werror=implicit-function-declaration]
         if (from_hex_char(line[2*i]) !=
(ssl_session->session_id.data[i] >> 4) ||
         ^
packet-ssl-utils.c:4218:5: error: implicit declaration of function
'from_hex' [-Werror=implicit-function-declaration]
     if (!from_hex(&ssl_session->master_secret, line, len))
     ^
cc1: all warnings being treated as errors
make[5]: *** [libdissectors_la-packet-ssl-utils.lo] Error 1

Thanks,
Y.

Hi,

There are automated build, they are described here:
http://www.wireshark.org/docs/wsdg_html_chunked/ChIntroAutomated.html

The last build results are here:
http://buildbot.wireshark.org/trunk/one_line_per_build

The problem you current have was already fixed in current trunk some
hours ago.

Hauke



___________________________________________________________________________
Sent via:    Wireshark-dev mailing list <wireshark-dev () wireshark org>
Archives:    http://www.wireshark.org/lists/wireshark-dev
Unsubscribe: https://wireshark.org/mailman/options/wireshark-dev
             mailto:wireshark-dev-request () wireshark org
?subject=unsubscribe

___________________________________________________________________________
Sent via:    Wireshark-dev mailing list <wireshark-dev () wireshark org>
Archives:    http://www.wireshark.org/lists/wireshark-dev
Unsubscribe: https://wireshark.org/mailman/options/wireshark-dev
             mailto:wireshark-dev-request () wireshark org
?subject=unsubscribe

___________________________________________________________________________
Sent via:    Wireshark-dev mailing list <wireshark-dev () wireshark org>
Archives:    http://www.wireshark.org/lists/wireshark-dev
Unsubscribe: https://wireshark.org/mailman/options/wireshark-dev
             mailto:wireshark-dev-request () wireshark org?subject=unsubscribe

  By Date           By Thread  

Current thread:
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]
AlienVault