Home page logo
/

wireshark logo Wireshark mailing list archives

Re: recent buildbot fuzz failures
From: Gerald Combs <gerald () wireshark org>
Date: Thu, 24 Jan 2013 09:58:40 -0800

On 1/23/13 7:46 PM, Jeff Morriss wrote:
Hi Gerald,

The buildbot's been generating a lot of fuzz failure bugs recently--none
of which I've been able to reproduce in any of the supported trunks
(Valgrind is silent too).

Any idea what's going on?

The last fuzz failure log says this (which doesn't make sense):

    /home/wireshark/menagerie/menagerie/9460-test.pcap: (-nVxr) (-nr)  OK

ls: cannot access
/dev/shm/buildbot/clangcodeanalysis/menagerie-fuzz/fuzz-*.pcap: No
such file or directory

In order to improve performance and reduce the I/O load I've been using
/dev/shm (which uses tmpfs) as the temporary directory for fuzzing.
However, it looks like the contents of /dev/shm disappear and reappear
periodically. The buildbots complain about missing files but when I
check they're there. I'm not sure what's causing it. Maybe a cron job or
daemon periodically clobbers and un-clobbers /dev/shm?

I moved fuzzing to its own mount point. Hopefully Buildbot will stop
complaining.
___________________________________________________________________________
Sent via:    Wireshark-dev mailing list <wireshark-dev () wireshark org>
Archives:    http://www.wireshark.org/lists/wireshark-dev
Unsubscribe: https://wireshark.org/mailman/options/wireshark-dev
             mailto:wireshark-dev-request () wireshark org?subject=unsubscribe


  By Date           By Thread  

Current thread:
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]
AlienVault