Home page logo
/

fulldisclosure logo Full Disclosure mailing list archives

[SECURITY] CVE-2011-0533: Apache Continuum cross-site scripting vulnerability
From: Brett Porter <brett () apache org>
Date: Fri, 11 Feb 2011 01:19:40 +1100

CVE-2011-0533: Apache Continuum cross-site scripting vulnerability

Severity: Important

Vendor: 
The Apache Software Foundation

Versions Affected:
Continuum 1.3.6
Continuum 1.4.0 (Beta)
The unsupported versions Continuum 1.1 - 1.2.3.1 are also affected.

Description:
A request that included a specially crafted request parameter could be
used to inject arbitrary HTML or Javascript into Continuum project
pages.

Mitigation:
Continuum 1.3.6 and earlier users should upgrade to 1.3.7

Continuum 1.4.0 (Beta) users should apply the following patch:
http://svn.apache.org/viewvc?view=revision&revision=1066056

Credit:
This issue was discovered by Tal Be'ery of Imperva.

References:
http://continuum.apache.org/security.html

--
Brett Porter
brett () apache org
http://brettporter.wordpress.com/
http://au.linkedin.com/in/brettporter




_______________________________________________
Full-Disclosure - We believe in it.
Charter: http://lists.grok.org.uk/full-disclosure-charter.html
Hosted and sponsored by Secunia - http://secunia.com/


  By Date           By Thread  

Current thread:
  • [SECURITY] CVE-2011-0533: Apache Continuum cross-site scripting vulnerability Brett Porter (Feb 10)
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]
AlienVault