Home page logo
/

fulldisclosure logo Full Disclosure mailing list archives

[Security-news] SA-CONTRIB-2013-008 - CurvyCorners - Cross Site Scripting (XSS) - module unsupported
From: security-news () drupal org
Date: Wed, 23 Jan 2013 17:58:09 +0000 (UTC)

View online: http://drupal.org/node/1896718

  * Advisory ID: DRUPAL-SA-CONTRIB-2013-008
  * Project: CurvyCorners [1] (third-party module)
  * Version: 6.x, 7.x
  * Date: 2013-January-23
  * Security risk: Moderately critical [2]
  * Exploitable from: Remote
  * Vulnerability: Cross Site Scripting

-------- DESCRIPTION  
---------------------------------------------------------

The CurvyCorners module enables you to create rounded corners on HTML block
elements.

The module doesn't sufficiently filter user entered text when being
displayed.

This vulnerability is mitigated by the fact that an attacker must have a role
with the permission "administer curvycorners".


-------- CVE IDENTIFIER(S) ISSUED  
--------------------------------------------

  * CVE-2013-1393

-------- VERSIONS AFFECTED  
---------------------------------------------------

  * All CurvyCorners 6.x-1.x versions.
  * All CurvyCorners 7.x-1.x versions.

Drupal core is not affected. If you do not use the contributed CurvyCorners
[3] module, there is nothing you need to do.

-------- SOLUTION  
------------------------------------------------------------

Install the latest version:

  * If you use the CurvyCorners module, uninstall the module - there is no
    patch available to fix this issue

Also see the CurvyCorners [4] project page.

-------- REPORTED BY  
---------------------------------------------------------

  * rickauer [5]

-------- FIXED BY  
------------------------------------------------------------

Not applicable.

-------- COORDINATED BY  
------------------------------------------------------

  * Greg Knaddison [6] of the Drupal Security Team

-------- CONTACT AND MORE INFORMATION  
----------------------------------------

The Drupal security team can be reached at security at drupal.org or via the
contact form at http://drupal.org/contact [7].

Learn more about the Drupal Security team and their policies [8], writing
secure code for Drupal [9], and securing your site [10].


[1] http://drupal.org/project/curvycorners
[2] http://drupal.org/security-team/risk-levels
[3] http://drupal.org/project/curvycorners
[4] http://drupal.org/project/curvycorners
[5] http://drupal.org/user/69553
[6] http://drupal.org/user/36762
[7] http://drupal.org/contact
[8] http://drupal.org/security-team
[9] http://drupal.org/writing-secure-code
[10] http://drupal.org/security/secure-configuration

_______________________________________________
Security-news mailing list
Security-news () drupal org
Unsubscribe at http://lists.drupal.org/mailman/listinfo/security-news

_______________________________________________
Full-Disclosure - We believe in it.
Charter: http://lists.grok.org.uk/full-disclosure-charter.html
Hosted and sponsored by Secunia - http://secunia.com/


  By Date           By Thread  

Current thread:
  • [Security-news] SA-CONTRIB-2013-008 - CurvyCorners - Cross Site Scripting (XSS) - module unsupported security-news (Jan 23)
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]