Home page logo
/

fulldisclosure logo Full Disclosure mailing list archives

CS and XSS vulnerabilities in SWFUpload
From: "MustLive" <mustlive () websecurity com ua>
Date: Sun, 10 Mar 2013 20:57:05 +0200

Hello list!

These are Content Spoofing and Cross-Site Scripting vulnerabilities in SWFUpload.

This is very popular flash-file, which is used at tens millions of web sites and in hundreds of web applications (such as WordPress, only this web application is used at more then 62 millions of web sites according to wordpress.com).

Last year I've wrote about XSS vulnerability in swfupload in WordPress (http://securityvulns.ru/docs28759.html) and in many other web applications. Neal Poole wrote in April 2012, when he disclosed XSS vulnerability in one swf-file in WordPress (CVE-2012-3414), that none developers of SWFUpload support their software. This application is still not maintained. Earlier I've informed two developers (on their e-mails) about these new vulnerabilities, but without any response from them, which was predictable due to Neal's experience.

-------------------------
Affected products:
-------------------------

Vulnerable are all versions of SWFUpload - SWFUpload v2.2.0.1 and previous versions. And all web applications with affected versions of SWFUpload are vulnerable. There are many such web applications, about many of them I've wrote last year, like WordPress.

Vulnerable are versions WordPress 2.5 - 3.3.1. The fixed version of swfupload.swf in WP 3.3.2 contain fix as for previous XSS, as for these CS and XSS vulnerabilities.

File swfupload.swf is bundled with WordPress 2.7 - 3.3.1. File swfupload_f9.swf is bundled with WordPress 2.5 - 2.7.1. In versions WP 2.7 - 2.7.1 both flash-files are contained.

-----
Fix:
-----

Use swfupload.swf from WordPress 3.3.2 and higher versions.

----------
Details:
----------

There are different names of files of SWFUpload: swfupload.swf, swfupload_f9.swf, swfupload_f8.swf, swfupload_f10.swf and swfupload_f11.swf. All of them are vulnerable, except swfupload.swf bundled with WordPress since version 3.3.2.

Content Spoofing (WASC-12):

http://site/swfupload.swf?buttonText=test%3Cimg%20src=%27http://demo.swfupload.org/v220/images/logo.gif%27%3E

It's possible to inject text, images and html (e.g. for link injection).

Cross-Site Scripting (WASC-08):

http://site/swfupload.swf?buttonText=%3Ca%20href=%27javascript:alert(document.cookie)%27%3EClick%20me%3C/a%3E

Code will execute after click. It's strictly social XSS.

Best wishes & regards,
MustLive
Administrator of Websecurity web site
http://websecurity.com.ua

_______________________________________________
Full-Disclosure - We believe in it.
Charter: http://lists.grok.org.uk/full-disclosure-charter.html
Hosted and sponsored by Secunia - http://secunia.com/


  By Date           By Thread  

Current thread:
  • CS and XSS vulnerabilities in SWFUpload MustLive (Mar 10)
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]
AlienVault