Home page logo
/

nmap-dev logo Nmap Development mailing list archives

nping fails to build on Mac OS X <10.6 because openssl is too old.
From: Daniel Johnson <daniel.johnson31 () gmail com>
Date: Sun, 9 Jan 2011 18:44:47 -0500

I maintain the nmap package for fink and after updating to 5.36TEST3 I've gotten reports from 10.5 users that it won't 
build. This is the failure in nping/Crypto.cc:

Crypto.cc: In static member function 'static int
Crypto::hmac_sha256(u8*, size_t, u8*, u8*, size_t)':
Crypto.cc:127: error: 'EVP_sha256' was not declared in this scope
Crypto.cc: In static member function 'static u8*
Crypto::deriveKey(const u8*, size_t, size_t*)':
Crypto.cc:262: error: 'EVP_sha256' was not declared in this scope
Crypto.cc:266: error: 'EVP_sha256' was not declared in this scope

Sure enough, EVP_sha256 is only available starting with openssl 0.9.8 and 10.5 only has 0.9.7. At the very least, 
nping/configure.ac should probably check for EVP_sha256 rather than just blindly trusting that the user's openssl is 
new enough.

I'm going to use fink's openssl100 to satisfy the dependency, but I thought it was worth bringing to your attention.

Daniel

_______________________________________________
Sent through the nmap-dev mailing list
http://cgi.insecure.org/mailman/listinfo/nmap-dev
Archived at http://seclists.org/nmap-dev/


  By Date           By Thread  

Current thread:
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]