Home page logo
/

oss-sec logo oss-sec mailing list archives

CVE-2011-4862 is not BSD-specific
From: Florian Weimer <fw () deneb enyo de>
Date: Sun, 25 Dec 2011 18:14:00 +0100

This is just a heads-up: CVE-2011-4862, a pre-authentication buffer
overflow in telnetd recently fixed by FreeBSD is not BSD-specific.  It
seems to have been added at MIT when the BSD telnetd was Kerberized,
and it ended up in the Heimdal recryptofication of Kerberos (from
where FreeBSD got it) and later in GNU inetutils.  I have reproduced a
pre-authentication segfault with both versions (as shipped by Debian).

The telnetd from netkit does not appear to be affected.


  By Date           By Thread  

Current thread:
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]
AlienVault