Home page logo
/

oss-sec logo oss-sec mailing list archives

CVE request: MantisBT before 1.2.13 match_type XSS vulnerability
From: David Hicks <d () hx id au>
Date: Fri, 18 Jan 2013 22:31:03 +1100

Hi list,

Jakub Galczyk discovered[1][2] a cross site scripting (XSS)
vulnerability in MantisBT 1.2.12 and earlier versions that allows a
malicious person to trick the browser of a target user into executing
arbitrary JavaScript via the URL: search.php?match_type="><script...

This vulnerability is particularly wide reaching due to search.php being
usable by anonymous users on public facing installations of MantisBT (no
user account required).

Patches against 1.2.x and master branches are attached and alternatively
available at [2].

References:
[1]
http://hauntit.blogspot.de/2013/01/en-mantis-bug-tracker-1212-persistent.html
[2] http://www.mantisbt.org/bugs/view.php?id=15373

The MantisBT project will release MantisBT 1.2.13 shortly and advise
popular Linux distributions packaging MantisBT to either apply the patch
or bump package versions to 1.2.13.

Can a CVE ID please be assigned to this issue?

With thanks,
David Hicks
MantisBT Developer
#mantisbt irc.freenode.net
http://www.mantisbt.org/bugs/

Bcc: mantisbt-dev () lists sourceforge net

Attachment: master-1.2.x_0001-Fix-15373-match_type-XSS-vulnerability.patch
Description:

Attachment: master_0001-Fix-15373-match_type-XSS-vulnerability.patch
Description:

Attachment: signature.asc
Description: This is a digitally signed message part


  By Date           By Thread  

Current thread:
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]