Home page logo
/

nmap-dev logo Nmap Development mailing list archives

Re: Version display patch
From: David Fifield <david () bamsoftware com>
Date: Tue, 8 Feb 2011 11:51:33 -0800

On Tue, Feb 08, 2011 at 10:27:02PM +0530, ambarisha b wrote:
That's a linker error.pcap_version was not from the external
interface.In windows ,may be that internal library file isn't linked
with nmap.cc.Anyway I have removed the pcap_version and added
pcap_lib_version() which is part of the external interface.I setup a
windows test environment and it compiled fine.I have attached the
updated patch.

Great job! I made some more changes and committed this as r22206. I'll
follow up with ideas about indicating whether the Nmap-included versions
of the libraries are used or system versions.

David Fifield
_______________________________________________
Sent through the nmap-dev mailing list
http://cgi.insecure.org/mailman/listinfo/nmap-dev
Archived at http://seclists.org/nmap-dev/


  By Date           By Thread  

Current thread:
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]